E Rider Forums Our Community Help!! New Model 15 – Max out at 20kmph and only did 15km on a full charge

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9972
    JoeR
    Participant

    Hi,

    Can anyone help me out, as I said I took my new model 15 for a test run to my work before my work reopens but it didn’t seem to have the power I was hopping for even with peddling I couldn’t get above 20kmph and it barely made it to my work. My work is only 9 miles away and I should be able to get 20-25 miles on a charge according to the site. Can anyone help me out, I don’t know if it’s something I need to do with it or if something is wrong with.

    It came fully built up and I fully charged the battery the night before, on my journey to work I don’t have any real hills to go up and it’s mainly flat going all the way.

    #9975
    Paul IOM
    Participant

    It might take a couple of re-charges before the battery is at peak performance, try it and see

    #9977
    Ken Ferguson
    Keymaster

    Hi Joe

    Our customer service will respond to you directly to solve the problem

    Regards

    #9988
    Weeble
    Participant

    I Bought a second hand one, And Mine struggles to work too However it’s probably because it’s mainly uphill all the way, Not Ideal but saving for a more powerful E bike, I’m currently buying odd parts to get it like new. Tim has been most helpful, Reasonable prices and delivery normally within 48 hours!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.